freunde.ma-nic.de


Linux On Mobile reshared this.

Marco R. friendica
Jetzt mein # Favorit: #!!!

Marco R. friendica
# # erinnert mich irgendwie an den Film "Eurovision" mit Will Ferrell.

Marco R. friendica
# Countdown startet auf One und Barbara Schöneberger sieht mal wieder echt Hammer aus!

@Friendica Support When I create a post via the twitter API and then want to see the conversation via /api/conversation/show, it says the conversation is not available (probably because it is still the old id, which is higher than the id in the Mastodon API). Worse still is the fact that the return error message is a html and not JSON!
Friendica Support reshared this.

2 people reshared this

Marco R. friendica
Coole DVD von meinem Lieblings-Videoverleih #.

#


Marco R. friendica
@Friendica Support

The API /account/verify_credentials shows an http error page "Unauthorized" when the password is wrong. I think it should return a JSON accoring to /help/api. Was that changed lately?
Friendica Support reshared this.

Marco R. friendica
In the latest GWO Podcast the author struggles to understand the concept of KActivities. Just as almost every @KDE user, I guess...

GNU World Order Linux Cast: gnuWorldOrder_456

Mediendatei: http://gnuworldorder.info//audiophile/gnuWorldOrder_456_ogg.ogg
@KDE

#Librem5 Daily Driver challenge 1

They have podcasts controls in the lock screen! Pretty amazing.


# daily driver challenge

Wow! Gnome Weather with nice overview and data provided by my favorite meteorological institute ☺



Librem5 daily driver challenge 4

I switched from Gnome Podcasts to Kasts. It has no OPML import yet, but a nice search function. There are far more options for episode handling and even a sync with a Nextcloud app! Gnome Podcasts becomes unusable after a while as there is no right click on the phone (which is needed for episode deletion, and there is no auto deletion!).

@Purism Where can I help with the translation of the # GUI? And how do I get my app Friendiqa into the store?

I really love that GNOME Web/Epiphany, one of my favourite browsers, is also the default browser on # .

#Librem5 daily driver challenge 5

Many dialogs are not fitted to the screen as one can see in this screenshot. 😞


#Librem5 daily driver challenge 3

Screen got blank, probably due to low power, but didn't react after plugged in. Took me some time to find out that you have to held down the power button for a whole 15-18 seconds to reboot!

#Librem5 Daily Driver challenge 2

5.5 hours battery life with continued podcast listening and some light surfing. Not in the range of a modern Android phone, but not bad either.😀

Why is the internationalisation on # that bad? Don't they use the translations from #.

Habe gerade unterschrieben, weiss nicht, ob es was bringt...😟

https://campact.org/klima-tempolimit-emum

Friendiqa version v0.6.5

I published a new version of Friendiqa, a mobile and Desktop app for Friendica (more info at https://friendiqa.ma-nic.de ).
The latest version fixes a bug for replies in Friendica 3/2022 . The image download from the gallery works again - yay!
There are also some additional emojis.

You need to remove your account and add it again, because the newsitem id changed in the API in Friendica 03/2022.

The app is available for Android, Linux (Arch Linux and a x86 Flatpak) and Linux Mobile (arm64 Flatpak).

Additional stuff from v0.6.4, if you missed that one:
* Search for new contacts (hashtags, names)
* Filter contacts
* many new emojis
* Rebuild contacts handling due to buggy Contacts API
* Removed permissions for new messages due to buggy Contacts API
* Sync all accounts in background (not only active)

Twitter API deprecated?

!developers In the last release, the old API became worse again. The api/friendica/notification is not existing anymore despite being in the documentation. The API /conversation/show have in_reply_to_I'd which make not sense. In the API /statuses/friends_timeline the news have three user objects which are all the same, even for reposts. For posts with embedded content the images are not in the attachments as was the case in earlier versions.

All this leads me to the conclusion, that these APIs are not in the developers focus, are not tested afterbchanges and degrade over time.

Are App developers required to use the Mastodon API?

Cheers, Marco
Michael Vogel friendica (via ActivityPub)
It will be part of the next release. But it would be much better if you use a server with the develop branch, this speeds up development and tests.
Then I will publish a fixed version which uses the Mastodon API for replies until the next Friendica version. It makes no sense to have a Social Media App where the user cannot reply to a post.






!Friendica Support
The API /api/v1/accounts/:id/following with my account Id returns an empty list. Is that an error in Friendica or did I do something wrong?
Friendica Support reshared this.
Michael Vogel friendica (via ActivityPub)
That should work.


Kann mich nur aufregen über den Unsinn, den Tim Pritlove verbreitet...

Logbuch:Netzpolitik: LNP420 Digitalisierungsfehler https://logbuch-netzpolitik.de/lnp420-digitalisierungsfehler
Ich finde Linus Neumann halt ziemlich gut und finde seine Beiträge immer sehr interessant. Aber der Unsinn bezüglich Interoperabilität von den beiden war schon schwer zu ertragen.

@helpers The api /api/conversation/show returns strange values in the new Friendica version 02/2022. The in_reply_to_status_id returns a value that has no relation to any of the id in the conversation. ☹

Nice podcast with a deep dive into Akonadi: GNU World Order Linux Cast: gnuWorldOrder_443

http://gnuworldorder.info//audiophile/gnuWorldOrder_443_ogg.ogg

@KDE
@KDE
http scheint nicht zu funktionieren.
Tatsächlich nicht!

Purism, whats wrong with your build process? The name of the program is gnome 42 (as required by apt), not gnome 46... ☟

#Librem5

João Azevedo mastodon (AP)
that package is part of a meta package called: librem5-base, that pulls default packages to be installed on a pureOS image for a Librem 5. And also sets some default configs.

It's not a gnome package per se.

Some of the packages that are installed using that metapackage are from gnome yes, but not all.

And that meta package; since it is not a gnome package, follows it's own version scheme.
It may be true, that they have other version schemes, but the repo says otherwise. An apt upgrade results with a 404 error for these packages, because it is looking for files with a 42 name.
João Azevedo mastodon (AP)
What version of PureOS are you using: Amber or Byzantium? And on what hardware?
Now the upgrade went through. Probably I just updated at the wrong time. ☺
It is Byzantium on a Librem5.

Ich habe meine monatliche Spende an @Corona Contact Tracing Germany mal erneuert. Wer weiß, wie lange die App noch gebraucht wird...


Typischer 1. Januar...


Der @BfDI verschickt die Pixi-Bücher über eine gemeinnützige Gesellschaft für psychisch Erkrankte. Nett!

@BfDI

Wieso ist der Hub auch wieder nur auf Github? So kann ich meine APP weder auf Flathub noch auf AppimageHub veröffentlichen. Zum Glück kann man auch dezentrale Repos hosten. Aber ohne Microsoft-/Github-Account hat man keinen Zugang zu den zentralen Repositories...

AppImageHub https://appimage.github.io/apps/

Initial version oft Friendiqa on Librem5. Still some bugs and no localisation (but that is a general problem on Librem5 PurismOS).


Windows 11 blocks Edge browser competitors from opening links

https://www.ctrl.blog/entry/microsoft-edge-protocol-competition.html
Later posts Earlier posts